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Introduction  

Suppose you want to make architectural, structural, mechanical, electrical and plumbing models of a 
building using Autodesk® Revit® but you don't have any practical experience of using Revit, then this 
book is for you. You will start from scratch and the book will guide you in step by step procedures to 
develop the models. I have tried to include all the information needed to develop the models in the book. 
I hope you will not be stuck at any point and waste your time in searching Help, Internet or other books 
to work on the topics.  

The book doesn't teach you lessons to remember or doesn't ask you questions to answer. From Chapter 
1, you start your model and by the end of each chapter, you will see that a part of the model is complete. 

The book has three parts, Architecture, Structure and MEP. You start with making architectural model. 
When it is complete, you will use it to extract information for Structural model. In the last part, you will 
add services (air-conditioning, lighting, electrical and plumbing) to your architectural model (used as 
linked model). 

Starting Point: 
To work on each part, you will need a starting project. These projects can found in the download folder 
as explained below. 

If you want to work on Architectural model only, start from Chapter 1. 

If you want to work on Structural model only, start from Chapter 2 and jump to Chapter 12. 

If you want to work on AC Design only, start from Chapter 17. 

If you want to work on Lighting and Electrical Design only, start from Chapter 22. 

If you want to work on Plumbing Design only, start from Chapter 24. 

Download Folder: 

You download the required files from BimBook folder at 
http://www.keepandshare.com/doc20/show.php?i=2635007&cat=2  
and save them on your hard disk.  

• Keep all files in the same folder.  
• Unzip Join32.zip. Run Join32.exe.  
• One by one, open all *.rvt files in Revit and save them again. 
• Delete all 001, 002 etc. files. 

E-mail for Suggestions: 

bimbooktech@gmail.com 

What you accomplish in each chapter: 

Part 1 . Architecture 
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Chapter 1 
You setup levels, make grids and set the angle of true north. 

Chapter 2 
You make structural columns and shear walls. 

Chapter 3 
You work on the Ground Floor level. You make walls, floor, rooms, doors, windows, stairs and ceilings. 

Chapter 4 
You work on Pavement level. You make stairs and ramp at entrance. You also make pavement floor. 

Chapter 5 
You work on First Floor level. You copy walls, doors and windows from Ground Floor level and edit 
them according to the plan. 

Chapter 6 
You work on the Roof level. You make walls and roof. 

Chapter 7 
You work on the Sit plan. You make Boundary Wall, Pavement Curb, Roads and add planting, Parking 
Spaces, vehicles and other site components. 

Chapter 8 
You extract building information from the model in form of schedules. You make door and room 
schedules in different forms. 

Chapter 9 
You will present the model in the form of sheets. You make a title block. On this title block, you make 
sheets for ground floor plan, first floor plan, site plan and schedules. 

Chapter 10 
You make a callout from a section view. You add material tags showing structure of floor and wall. You 
present this information on a sheet. 

Part 2 . Structure 

Chapter 11 
You start a new structural project and copy levels, grids, columns, shear walls and stairs from the 
architectural model. 

Chapter 12 
You work on Foundation level. You make isolated foundations under the columns and wall foundations 
under the shear walls. 
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Chapter 13 
You work on Ground Floor level. You make ground beams, slab on grade and slab edges. 

Chapter 14 
You work on First Floor level. You copy beams from Ground Floor level and edit them to make drop 
beams and hourdi beams. You make one-way and two-way hourdi slabs. In some part, you make solid 
slab. 

Chapter 15 
You work on Roof level. You copy drop beams from First Floor level. In one part of the roof, you add 
pre-cast hollow core slabs. In another part, you make waffle slab. 

Chapter 16 
You present the structural plans in the form of sheets. 

Part 3 . MEP 

Chapter 17 
You start a new MEP project. You link it with the architectural model and prepare it to add services. 

Chapter 18 
You divide the model in spaces and zones. You set energy analysis properties of zones. 

Chapter 19  
You make energy analysis of the model to calculate heating and cooling load of spaces, zones and the 
whole building. On the base of this calculation, you add air terminals on the ceiling and adjust their air 
flow. 

Chapter 20 
You add VAV boxes and make secondary air supply system by automatically connecting VAV boxes 
and air terminals with ducts. You run a primary duct connecting VAV boxes with the air conditioner. 
You make automatic duct sizing and repair any problems in the ductwork. 

Chapter 21 
You present the duct layout plans and 3D views of AC system on sheets. 

Chapter 22 
You make lighting analysis of the building and add lighting fixtures in different spaces according to the 
lighting requirement. 

Chapter 23 
You place distribution panel boards in mechanical/electrical rooms. You add lighting switches and 
power receptacles in different rooms. You make electrical wiring for lighting systems and power 
receptacles. You present the wiring diagrams on sheets. 
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Chapter 24 
You copy plumbing fixtures from architectural model. You add more plumbing fixtures and fittings. 
You make pipe work for sanitary, vent, cold water and hot water systems. You make automatic pipe 
sizing. You present different plumbing systems (in plans and 3D views) on sheets. 
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BIM Project by Imtaar 

1 New Architectural Project 
Before starting a new Architectural Project, you need to get familiar with Revit environment. You will 
know where different components are stored. You will explore different parts of the user interface. Then 
you will start your project by defining levels of your building (in an elevation view) and grid layout (in a 
floor plan view). 

1.1 Revit Options 
After you install Revit, sometimes you may need to setup the places where libraries for components (or 
blocks), templates and other elements are saved. It saves time when you want to find different elements. 

Normally these places are setup by the install process.  But you may change them if you need. 

1. Install Autodesk Revit Software with US Metric content. 
2. If Revit Content is not downloaded then  

• Download US Metric Library. 
• Copy it in C:\ProgramData\Autodesk\RVT 201?\Libraries\. (You can copy it at any other 

place on your computer and set file locations properly). 

3. Open Revit Program. 

4. Click on  (Revit Button). 
5. Click on Options as shown in Fig 1.1. 

 

Fig. 1.1  – Revit Button 

6. Check that File Locations for User Files and Family Template Files are set properly (Fig. 1.2). 
7. Check that Places for Metric Library and Metric Detail Library are set properly. 
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 Fig. 1.2  – Setting File Locations 

1.2 The Revit Project 
What you make in Revit is a Project. A Revit Project consists of many Views (Plans, Elevations, 
Sections etc.), Schedules (Tables), Drawing Sheets etc. These elements are arranged in a tree view 
called the Project Browser (Fig. 1.3). 

Each element has different properties. These properties are shown in Properties Palette (Fig. 1.3).  

Any change in an element in one view or schedule revises all other views or schedules instantly. That is 
why the name Revit (Revise instantly). Different views can have different visibility settings. 
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1.3 The User Interface 
When you start the Revit program, what you see on the desktop is the user interface. Different tools are 
arranged in the form of a Ribbon. The default user interface shows the Ribbon, Palettes and a large 
drawing area where you draw different elements of your Revit project. In a plan view, you can see the 
four elevation symbols. 

 

Fig. 1.3  – Revit User Interface 

1. The Ribbon consists of Tabs, Panels, Tools etc. 
2. Each TAB  (Architecture, Structure, System, Insert ...) represents a particular topic. 
3. When you press a tab, all panels change according to the topic of the tab. 
4. Each panel contains tools to do a particular job. 
5. A contextual tab appears to show tools to edit/modify a particular object. When job is done, the 

contextual tab disappears. 
6. The Option Bar contains textboxes, checkboxes, radiobuttons etc. to gather information about the 

object under work. 
7. In the drawing area, you sketch/modify different Revit elements. 
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8. You can put frequently used tools on QAT (Quick Access Toolbar). Right-click any tool and select 
Add to QAT. On far right of QAT, there is dropdown box which controls the visibility of the tools on 
QAT.      

 

Fig. 1.4  – Visibility settings for Revit User Interface components 

9. If you do not see the Project Browser, then on View tab → Windows panel → User Interface 
dropdown → Select Project Browser (Fig. 1.4).   

10. If you do not see the Properties palette, then on View tab → Windows panel → User Interface 
dropdown → Select Properties.   

11. On lower part of the Revit window, you see the View Control bar, which contains tools to control the 
view. Bring cursor on any tool to see its description (Fig. 1.5). 

 

Fig. 1.5  – View Control Bar Tools 

1.4 Initial Setup 
Before you start sketching the elements of your Revit project, you need some preparations. 

1.4.1 Starting a New Architectural Project 
You will start your work with a project ArchProject.rvt. You will download this file from Download 
Folder (page v). 

1. Open Revit → Projects → Open (Fig. 1.6). 
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Fig. 1.6  – Opening a new project 

2. Select arch_project.rvt  → Open 
3. Save Project As Arch01  

1.4.2 Enter Project Information 
At the start of a new project, you will enter some information about your project. This information will 
be used in different places. (You can enter or revise this information at some later time also.) 

1. Manage Tab (Fig. 1.7).  
2. Settings Panel. 
3. Click Project Information. 

 

Fig. 1.7  – Project Information tool 

4. Enter all the information (Fig. 1.8). 

 

Fig. 1.8  – Project Information table 
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1.4.3 Set Project Units 
You can set project units as millimeters, meters etc. 

1. Manage Tab  
2. Settings Panel 
3. Click Project Units 
4. Set Project Units = Meters with rounding up to 2 decimal places  as shown in Fig 1.9. 

 

Fig. 1.9  – Project Units 

1.5 Project Levels 
First thing you add to a technical project are levels. By default, 2 levels (Level 1 and Level 2) and their 
Floor Plan and Ceiling Plan views are present. You can add more levels in an Elevation or Section view. 

1.5.1 Plan Views 
Each level has associated plan views e.g. Floor Plan view, Structural Plan view, Ceiling Plan view. 
Different plan views are grouped in the Project Browser. When you create a new level, you can decide 
which plan views you want to create with it. Any plan view can be created or deleted later on. 

1. If a level is deleted, all of its associated plan views are also deleted. 
2. If a plan view is not created or it is deleted, it can be created again with all the elements present in it. 

1.5.2 Add Levels 
You will add more levels showing their associated plan views in the project browser.  

1. In Project Browser, under Elevations, double-click South (Fig. 1.10). You will see that  01 Level and 
02 Level are already present. 

2. Architecture Tab  
3. Datum Panel → Click Level. 
4. In Type selector, select Level : 8mm Head (Fig. 1.11). 
5. On Option bar click Plan View Types → Select Floor Plan (Fig. 1.11). 
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Fig. 1.10 – Level tool to draw new levels 

 

Fig. 1.11 – Selecting Plan View Types for new levels 

6. Draw three levels below 01 Level and three levels above 02 Level. (Draw at any height. Level names 
and level heights will be adjusted later). To draw a level: 

• Bring cursor to left side. When you see dashed aligning line, click. 
• Bring cursor to right side. When you see dashed aligning line, click. New level is created. 

 

Fig. 1.12 – Selecting Plan View Types for new levels 

7. All new levels appear in Project Browser, under Floor Plans node. 
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1.5.3 Change Levels Symbols 
The level symbols you see in the project are circles. Sometimes you want to change them to triangles. 
First you will load the triangle symbol family from the library. Then you will make a new level type. 
You will edit type and change the symbol.   

1. Insert Tab. 
2. Load From Library Panel → Click Load Family. 
3. Annotations → M_Level Head - Triangle Spot.rfa. 
4. In Project Browser, under Elevations, double-click South. 
5. Select a Level. 
6. On Properties Palette , click Edit Type (Fig. 1.12). 
7. Type Properties dialog box will appear. 
8. In Type Properties dialog box, click Duplicate button → Enter Name = 8mm Head Triangle Spot → 

OK. 
9. Under Graphics group, select Symbol = M_Level Head - Triangle Spot → OK. 
10. New type of level is created. 

 

Fig. 1.12 – Selecting Plan View Types for new levels 

11. Select other levels (press CTRL and select all levels) → In type selector, select 8mm Head Triangle 
Spot. Level Symbols will change as shown in Fig. 1.13. 

1.5.4 Adjust Levels 
The levels you just added have different names and elevations as seen on the Level Symbol. You need to 
change both name and elevation for each level. 

1. Click on a Level. 
2. In Properties, change Name (or click (slowly) twice on Name and change). 
3. "Would you like to rename corresponding views?"  Yes 
4. In Properties, change Elevation (or click (slowly) twice on Elevation and change). 
5. Adjust all levels as shown in Fig 1.13. 

1.5.5 Make Elbow in Level Line 
Some level lines are very close and the information overlaps. You can bend the level line by making an 
elbow or kink. 

1. Click on a Level. 
2. You will see a Break Control on the Level Line (Fig. 1.15).  
3. Click on the Break Control. 
4. The Level Line will bend. 
5. Adjust the bend points. 
6. Align bend points of all levels (Fig. 1.15). 
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Fig. 1.13 – Project levels                                              Fig. 1.14 – Horizontal Grid Lines 

 

 

Fig. 1.15 – Elbow in Level Line 

1.6 Grids 
After the levels, the next thing in a technical project is Grid Lines. The grid lines are drawn according to 
module. Most of the building elements (columns, walls, foundations etc.) are drawn on grids.  

1.6.1 Horizontal Grids 
You will draw grids on a module of 0.6m.  
1. Project Browser → Floor Plans → double-click 01 GF. 
2. On Architecture tab → Datum panel → Click Grid. 
3. In Type selector, select Type = 6.5mm Bubble. 
4. Near the South Elevation, click left then click right to draw a grid line between West and East 

Elevations (Fig. 1.16). 
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Fig. 1.16 – Horizontal Grid Line 

5. See that the number inside the Bubble is 1. (If not, then click on number 2 times and change it to 1). 
6. Architecture Tab → Datum Panel → Click Grid. 
7. You will see Contextual Tab of Modify | Place Grid. 
8. Click on Pick Lines (Fig. 1.17). 
9. Offset = 4.2 
10. Hover over the Grid 1. 
11. You will see a dashed blue line above or below the Grid 1 (depending on where you place the mouse 

pointer). 

 

Fig. 1.17 – Pick Lines tool on Modify | Place Grid Contextual Tab 

12. When you see the dashed blue line above the Grid 1(Fig. 1.18), click. 
13. You will see the Grid 2. 
14. In this way draw other horizontal Grid lines at offset distances 4.8, 4.8, 4.8, 6.6, 2.4, 6.0 as shown in 

Fig. 1.14. 

 

 

Fig. 1.18 – Grid Line Offset. 

15. The grids can be drawn in the following ways also: 
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• Draw all the grids by clicking left and right (Fig. 1.16) and the adjust distances from Grid 2 
upwards. 

• Install Grid Generator utility and use it. 

1.6.2 Vertical Grids 
1. Now draw a vertical grid line from down to up near the west elevation. 
2. Change its number (in the bubble) to A as shown in Fig. 1.19. 
3. Now Pick Lines for other grid lines at Offset = 5.4, 2.4, 6.6, 4.8, 4.8, 4.8, 4.2 

 

Fig. 1.19 – Vertical Grid Lines 

1.6.3 Position Grids 
1. Select a horizontal grid and drag its Drag Circles to adjust its length from left and right 
2. Similarly adjust length of vertical grid 
3. Select all the grid lines by dragging a window from top-right to lower-left 
4. Bring mouse pointer on any line. A four-sided arrow will appear 
5. Drag to bring all the grids approximately in the middle of the Elevations. 

1.6.4 Change Grid Length 
If we select a Grid and drag the circle near the Head or Bubble, length of all locked Grids change. To 
change the length of one Grid, we must unlock it. 

1. Click on Grid 5. A lock appears 
2. Click on lock to unlock it as shown in Fig. 1.20.  

 

Fig. 1.20 – Grid Line End 

3. Drag the Circle on right side to bring it near Grid C. 
4. In this way change the length of other Grid lines as shown in Fig. 1.21. 
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Fig. 1.21 – Project Grid 

1.7 True North 
1. Project Browser → under Floor Plans → double-click Site.  
2. Press VG (on keyboard) to show the Visibility/Graphics dialog Box. 
3. On Model Categories tab, expand Site and select Project Base Point → OK (Fig. 1.22). 
4. You will see the Project Base Point in the view. 
5. Click in the center of Project Base Point. 
6. In Properties palette, change Angle to True North = 120º (Fig. 1.23). 
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Fig. 1.22 – Visibility/Graphics Overrides 

   

Fig. 1.23 – Setting True North 

7. Click  to Save Projet As Arch01. 
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2 Structural Elements 
Now you can start drawing the building elements or components. You will draw structural components 
such as columns and shear walls. If a component family is not loaded in the project, then you will load it 
from the component library or folder. 

Sometimes you need to place an element whose properties (width, height etc.) are different from those 
found in the library. You can select an element, duplicate and rename it. Then you can change its 
properties as needed. 

2.1 Columns 
Rectangular concrete columns will be placed on grid intersections. Each column will have base level at 
Foundation and top level at Roof. 

2.1.1 Add New Concrete Columns at Foundation Level 
You will add concrete columns 400 x 600 mm going from Foundation level to Roof level. This type of 
column is not available in the library but 450 x 600 mm is available. You will use this type to make a 
new type. 

1. Open Project Arch01. 
2. Save Project As Arch02. 
3. Floor Plans → Foundation. 
4. Structure Tab → Structure Panel → Click on Column Tool. 
5. Mode Panel → Load Family. 
6. You should see subfolders in US Metric folder. If not, then make settings as shown in Fig. 1.2. 
7. Structural Columns → Concrete → M_Concrete-Rectangular-Column.rfa. 
8. In Properties palette → Type selector → select Type = M_Concrete- Rectangular -Column : 450 x 

600 mm (Fig. 2.1). 

 

Fig. 2.1  – Edit Column type 

9. In Properties palette , click Edit Type. 
10. Click Duplicate → Name = 400 x 600 mm. 
11. b = 0.4, h = 0.6 
12. Placement Panel → select Vertical Column (Blue). 
13. On Option bar, set Height = Roof. 
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14. Multiple Panel → At Grids (Fig. 2.2). 

   

Fig. 2.2  – Column placement                                                                             Fig. 2.3  – Finish 

15. Draw a selection box (Right to Left) around all the grids → Click Finish (Fig. 2.3). 

2.1.2 Delete Extra Columns 
Columns are placed on all grid intersections. Some columns need to be deleted. 

1. Draw a selection box (Left to Right) around the grid B from Grids 3 to 7 to select columns at B2, B3, 
B4, B5, B6, B7 → Press Delete.   

2. Select C6, (press Ctrl) C7, F7 → Press Delete. 

2.1.3 Add a Column manually 
If a column is not on a grid intersection, it will not be drawn. You can draw this column manually. 

1. Structure Tab → Structure Panel → Click on Column Tool. 
2. Height = Roof (Fig. 2.2). 
3. In Properties palette → Type selector → select Type = M_Concrete- Rectangular -Column : 400 x 

600 mm. 
4. Add a column anywhere on grid C between grid 7 and grid 8 (Fig 2.4). 

 

 

Fig. 2.4  – Selection box for Columns 

5. Select this column. Temporary dimensions appear. Adjust its distance = 3.6m from grid 8. 
6. If the temporary dimension is not showing distance from grid 8, drag the witness line control (blue 

dot) to grid 8. The dimension will show distance of column from grid 8 (Fig 2.5). 
7. Click on number in temporary dimension → change → press Enter. 
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Fig. 2.5  – Selection box for Columns 

2.1.4 Rotate Selected Columns 
Some columns need to be rotated along the wall. This can be done by just pressing Space bar. 

1. Draw a selection box (Left to Right) around columns (close to columns) at the intersection of grids 
B-G and 6-8. 

2. Click on Filter → Click Check None → Select Structural Columns (Fig. 2.5). 

 

3. Press Space bar. All selected columns will be rotated by 90 º. 

2.1.4 Change Appearance of Columns 
In Foundation plan, the columns are shown with concrete pattern. You can change the appearance to 
Solid Black by editing the Structural Material.  

1. Draw a selection box (Right to Left) to select all. 
2. Click on Filter → Click Check None → Select Structural Columns (Fig. 2.5). 

 

Fig. 2.5  – Filter for Columns 

3. Properties Palette → Structural Material (Concrete, Cast-in-Place gray). Click on    (Fig. 2.6). 
4. In Materials Palette, Duplicate the Selected Material (right-click on material → Duplicate). 
5. Rename it as Concrete, Cast-in-Place gray col (right-click on material → Rename). 
6. Select Cut Pattern = Solid Fill, Color  = RGB 0, 0, 0 (Black) (Fig. 2.7). 
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Fig. 2.6  – Material for Columns 

 

Fig. 2.7  – Cut Pattern for Material 

7. The Foundation Plan view looks as shown in Fig 2.9. 
8. See 3D View.  

• Click on   on Quick Access Toolbar. 
• Project Browser → 3D Views → click on {3D}. 

9. You will see the 3D View. 

2.1.5 Room Bounding 
1. Floor Plans → 01 GF. 
2. Select all → Filter → Check None → Select Structural Columns only. 
3. In Properties palette, set Room Bounding = � False (Fig. 2.8). 

 

Fig. 2.8  – Remove Room Bounding property 
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Fig. 2.9  – Foundation Plan 

2.2 Shear Walls 
Shear walls are structural load bearing walls. They are constructed around stairs or elevators. Shear 
walls are continuous from Foundation level to Roof level. You will make a 250 mm thick wall for this 
purpose (245 mm concrete, 5 mm Plaster).  

1. Floor Plans →  Foundation 
2. Structure Tab → Structure Panel → Wall → Wall : Structural Wall (Fig. 2.10). 
3. Height = Roof 
4. In Properties palette → Type selector → select type = Basic Wall : Retaining - 300mm Concrete 
5. Click on Edit Type 
6. In Type Properties, click on Duplicate → Name = Shear - 250mm Concrete 
7. Under Type Parameters → Construction group → Structure → click Edit. 
8. Under Layers, change thickness of layer 2 to 0.248 (Fig. 2.11). 
9. Bring cursor on layer 1 and click (You will see a small arrow on left side). 
10. Press Insert.  
11. A new layer will be added above Core Boundary layer. 
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Fig. 2.10 – Edit Shear Wall type  

 

Fig. 2.11 – Edit Shear Wall structure  

12. Change Function to Finish 1 [4] (Fig. 2.12). 
13. Change thickness to 0.002. Wraps � 

14. Under Material, click on . Material Browser will open. 
15. Check if Library Panel is visible. If not, click on square in upper right corner. 
16. In Library Panel, click on Autodesk Materials. 
17. In materials list, click on Plaster then click on Up arrow. 
18. Click OK → OK. New material (Plaster) will be added. Click OK → OK (Material for layer 1 will 

be Plaster).  
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Fig. 2.12 – Edit Shear Wall material  

19. Edit Type → Under Type Parameters → Graphics group → Coarse Scale Fill Pattern = Solid Fill. 
20. On Modify | Place Structural Wall contextual tab → Draw panel → select Line tool. 
21. Set properties: Base Constraint = Foundation, Top Constraint = Up to level: Roof 

 

Fig. 2.13 – Shear Wall Properties  

22. Now draw the shear wall as shown in Fig. 2.14.  

• Click on A (intersection B7) – B (intersection A7) – C (Anywhere on grid A) – D (Anywhere 
on grid B) – E (intersection B6) – F (intersection A6) – Esc. 

• Click on G (mid point of  EF) – H (mid point of  CD) – Esc.  
• Select CD. Temporary dimensions appear. Click on number and change distance = 2.00 from 

grid 6. Press Enter.  

 

Fig. 2.14 – Shear Wall placement  
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23. Make sure that the plaster is on outer side. To do this, click to select each shear wall. You will see a 
double arrow. It should be on the outer side. If it is not, then click on the double-arrow (or press 
space bar) to bring it on the outer side. 

 

Fig. 2.15 – Shear Wall outer side  

24. Select the shear wall on grid A. 
25. Click on Edit Type 
26. In Type Properties, click on Duplicate → Name = Shear - 300mm Concrete 
27. Under Type Parameters → Construction group → Structure → click Edit 
28. Change thickness of layer 3 (Structure [1]) to 0.298. 

 

Fig. 2.16 – Shear Wall structure  

29. Click OK → OK. 
30. See 3D View as explained in step 8 of § 2.1.4. (On View Control Bar at the bottom, change Visual 

Style = Shaded) 

 

Fig. 2.17 – 3D view (Shaded)  

31. Click  to Save Project As Arch02. 
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